Page 1 of 1

How to disable the game pause on key "Lalt" ?

Posted: Tue Jul 18, 2017 5:30 pm
by manuk
hey,
in GameSDK when im in "windowed mode" ( fullscreen=0 )
if i press "Lalt", the game is pausing and the mouse cursor is unhiding...
any idea how could i disabled this ?
i didnt found anything in Cvars, DefaultProfile.xml and Cpp..

PS: im on 3.8.6

Re: How to disable the game pause on key "Lalt" ?

Posted: Thu Jul 20, 2017 2:55 am
by miravista
this also applies to CEV. Don't quote me, but this might be a sandbox only thing.
I use it to change cvars

Re: How to disable the game pause on key "Lalt" ?

Posted: Mon Jul 24, 2017 3:43 am
by fkhaller
If you go into the defaultprofile.xml in <projectfolder>/assets/libs/config, I think you should be able to turn off any keybinding if you just delete the xml line where that keybinding is defined. you should see something like this:

Code: Select all

<action name="show_mouse" onPress="1" onRelease="1" retriggerable="1" keyboard="Lalt"/>
Hope this helps.

Re: How to disable the game pause on key "Lalt" ?

Posted: Mon Jul 24, 2017 11:45 am
by manuk
i dont see any "show_mouse" actions in the defaultprofile.xml or Cpp... are sure about this ?

Re: How to disable the game pause on key "Lalt" ?

Posted: Mon Jul 24, 2017 12:01 pm
by mknmknmknjk
the function is in sanbox (editor) . the keybind xml is for game.

Re: How to disable the game pause on key "Lalt" ?

Posted: Mon Jul 24, 2017 12:22 pm
by fkhaller
i dont see any "show_mouse" actions in the defaultprofile.xml or Cpp... are sure about this ?
I did not look at it just thought it might be there might be called something else. Not sure if this works in editor, have not used it in awhile. A shot in the dark.