Page 1 of 1

Generate solution failed

Posted: Sat Feb 16, 2019 7:23 pm
by Azureusbin
Hello everyone, I can't generate solution.

the error message like that:
20190216162254.png
20190216162254.png (18.55 KiB) Viewed 652 times

Does anyone know how to fix this problem?

My Environment:
Win10 64bit
Visual studio 2015 Enterprise

Re: Generate solution failed

Posted: Wed Feb 27, 2019 5:10 pm
by Cry-Flare
Thanks for letting us know about this, it would be great if you can see if this works for you:

Install Python 3.7.
https://www.python.org/downloads/


Open the file:

Code: Select all

C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\CRYENGINE_5.5\Tools\CryVersionSelector\cryrun.py

Change this line:

Code: Select all

subprocess.run(command_str, cwd=solution_path, stdout=None, stderr=subprocess.PIPE, check=True, universal_newlines=True)

To this:

Code: Select all

subprocess.run(command_str.encode('utf-8'), cwd=solution_path.encode('utf-8'), stdout=None, stderr=subprocess.PIPE, check=True, universal_newlines=True)

Then open the command prompt and run this command:

Code: Select all

E:\CryVVVV\Tools\CryVersionSelector\cryrun.exe "engine_gen" "E:\CryVVVV\cryengine.cryengine"
Then let us know if you get any errors running this command.

Re: Generate solution failed

Posted: Tue Mar 12, 2019 7:02 am
by Azureusbin
Thanks for letting us know about this, it would be great if you can see if this works for you:

Install Python 3.7.
https://www.python.org/downloads/


Open the file:

Code: Select all

C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\CRYENGINE_5.5\Tools\CryVersionSelector\cryrun.py

Change this line:

Code: Select all

subprocess.run(command_str, cwd=solution_path, stdout=None, stderr=subprocess.PIPE, check=True, universal_newlines=True)

To this:

Code: Select all

subprocess.run(command_str.encode('utf-8'), cwd=solution_path.encode('utf-8'), stdout=None, stderr=subprocess.PIPE, check=True, universal_newlines=True)

Then open the command prompt and run this command:

Code: Select all

E:\CryVVVV\Tools\CryVersionSelector\cryrun.exe "engine_gen" "E:\CryVVVV\cryengine.cryengine"
Then let us know if you get any errors running this command.
Problem solved, and it is worked. Thanks you.