Page 1 of 1

anyone have a clue why every other time state machine messes up

Posted: Sat Jun 16, 2018 2:45 pm
by grb1212
signal graph door.jpg
signal graph door.jpg (173.55 KiB) Viewed 2369 times
state machine door.jpg
state machine door.jpg (164.75 KiB) Viewed 2369 times

Re: anyone have a clue why every other time state machine messes up

Posted: Sat Jun 16, 2018 2:52 pm
by grb1212
state op door.jpg
state op door.jpg (343.06 KiB) Viewed 2368 times



the door rotates the first time i reset editor and works every 2 times i go into game mode in editor


press Ctrl G > door works > press Esc > press Ctrl G > door doesn't work > press Esc > repeat cycle

Re: anyone have a clue why every other time state machine messes up

Posted: Wed Jun 20, 2018 4:42 pm
by Cry-Flare
Perhaps you could drop the .ent file here and people can take a look, It's hard to understand from the pictures alone as the text is pretty much illegible.

Re: anyone have a clue why every other time state machine messes up

Posted: Sat Jun 23, 2018 8:02 pm
by grb1212
newestdoor.rar
(3.27 KiB) Downloaded 71 times

Re: anyone have a clue why every other time state machine messes up

Posted: Sun Jun 24, 2018 5:00 am
by mknmknmknjk
check attachment

Re: anyone have a clue why every other time state machine messes up

Posted: Mon Jun 25, 2018 6:00 pm
by grb1212
EDIT: when i open doll.ent it shows nothing

i will look at this but for future reference to this question, i will add more information.

1st> I am using the Gamesdk.

2nd> im using lua to attach a sensor volume "with player attribute" to the gamesdk's localplayer

by lua i mean flow graph, Entity>AttachmentEx

this is the only method i know to have a player with sensor volume.

one of the moderates once sent me some examples but said they needed to be compiled, i know what compiling means but no clue how to do so.

check attachment

Re: anyone have a clue why every other time state machine messes up

Posted: Mon Jun 25, 2018 10:14 pm
by mknmknmknjk
copy ent file and paist and restart engine. if not show, restart engine.
i use ce5.5 preview4

Re: anyone have a clue why every other time state machine messes up

Posted: Mon Jun 25, 2018 10:24 pm
by grb1212
im using 5.5 preview 4 also

im genertated/repair meta data and restarted still nothing shows for doll.ent


copy ent file and paist and restart engine. if not show, restart engine.
i use ce5.5 preview4

Re: anyone have a clue why every other time state machine messes up

Posted: Tue Jun 26, 2018 12:31 am
by mknmknmknjk
check snapshot


and project link

https://pan.baidu.com/s/148Hn7AnNO6ttVWpNgjL2Ag
password 95es