Search found 25 matches

Re: Access violation after building C++ FPS template with no changes

Hi Flare, you must have missed my PS on my post. The print works as it should. There appears to be a typo for that function(Set vs Get). Here is the code from the header file for SetCharacterFile(). virtual void SetCharacterFile(const char* szPath); const char* SetCharacterFile() const { return m_ch...

Re: Access violation after building C++ FPS template with no changes

Hi Miron, thanks for clarifying the procedure for testing release builds. Does this also apply to CryEngine 5.4? C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\CRYENGINE_5.4\bin\win_x64_release contains a single .dll (CryScaleformHelper.dll) and win_x64_profile doesn't exist. None of the ot...

Re: Access violation after building C++ FPS template with no changes

I thought of a couple other things I could try. First - I generated an x86 project instead of x64. I did remember to update the Game.cryproject to point to the x86 Game.dll. Exact same symptoms, no crash in Debug but crashed in Release (same spot). Second - I downloaded 5.5 preview 3. That actually ...

Re: Access violation after building C++ FPS template with no changes

Hi Flare, thanks for taking a look at my problem. I added the pragma as you suggested but I wasn't able to get anymore information. I did tinker with it a bit more and I added a print after about line 26 so it looks like: m_pAnimationComponent->SetCharacterFile("Objects/Characters/SampleCharacter/fi...

Re: Access violation after building C++ FPS template with no changes

I stumbled on this today(emphasis mine): The Game Code solution can always be compiled in either Debug or Profile configuration. Compiling the Release configuration requires the access to full engine source code. http://docs.cryengine.com/display/CEPROG/Getting+Started+with+Game+Code# Is that page c...

Re: Access violation after building C++ FPS template with no changes

And one more thing, I tried adding prints to Player.cpp to try and figure out what is going on. I added this around m_pAnimationComponent->LoadFromDisk(): CryWarning(VALIDATOR_MODULE_GAME, VALIDATOR_WARNING, "GetControllerDefinitionFile %s\nGetMannequinAnimationDatabaseFile %s", m_pAnimationComponen...

Re: Access violation after building C++ FPS template with no changes

I'm still trying to get this to work, I noticed a couple things that I am not sure are right. 1) Running the "INSTALL" project from VS2015 errors out, complaining that boost is missing. Same failure in Debug and Release mode. Log output below. I did verify that there is no boost directory inside C:/...

Re: Access violation after building C++ FPS template with no changes

Not changing anything at all, not even assets. I am creating the C++ FPS template and trying to use it as is. I uninstalled 2015 express, then installed 2015 community. Unfortunately it still crashes in the same spot with the same message. For the record, I did delete the "solution" directory and re...

Re: Access violation after building C++ FPS template with no changes

I am absolutely positive I have made no changes at all. To be sure of this, I validated the engine through CRYENGINE Launcher, created a new C++ FPS project, build solution and run GameLauncher project. Crashes in the same spot with same messages. I did not change a single character of Player.cpp(or...

Go to advanced search